Creating Your First Company

The steps required to create a company will vary somewhat depending on which database type you have selected. If you are using one of the file based database formats (SQLite, MSAccess, or SQL Compact), you create a new company file by selecting File > New. This will open a file browse box where you can select the name and location of your company file.

Note: The default file extension will also vary depending on which database format you have selected. If you selected the default format of "SQLite", then the default file extension is ".tb3".

Enter the Company file name to be created, and select Save to create the company database file.

If you are using one of the server based database formats (MySql or Microsoft SQL Server), you create a new company file by selecting File > New. This will create a new company record, and then automatically open the Company properties dialog box where you can enter the new company name. Enter the company name and address, then click Save.

Once the company file or record has been created, the next step is to create the Periods information for this company. The Periods information that you provide will determine what reporting period is to be used, and which periods are available for storing historical information.

For example, if you will be storing annual calendar year information for the 2015 and 2016, then you should create two periods as shown below. Select Edit >Periods to open the Periods screen, then select New to create the new period records.

Each time you click the New button, a period setup dialog box opens that allows you to set the beginning and ending date of each period, and also select how the beginning balances will be created. If you will be importing the beginning balances from another source (Excel, QuickBooks, etc.), then select the choice to use a Zero opening balance type. This will allow you to later import the beginning balances for that period. If you already have balances in TBTools Trial Balance for the prior period, then you can select to create the period beginning balances by using the closing balances from the prior period. This is what some other software programs refer to as the annual "roll forward" process, where balances from one period are used to create the beginning or opening balances of the next period.